青いやつの進捗日記。

べんきょうのしんちょくをかいていきます。

SwiperをWebpackで利用するときは設定をしないとIEでのみエラーになる

Swiperというスライダーを作るときに便利なプラグイン。

swiperjs.com

もう超絶便利ですよね。

で、こいつをWebpackとかで使う際に注意が必要だと最近わかりました。

なぜかIEでだけ、普通に使ってるとJS全部機能しません。

【JS】スライダーのSwiperをwebpackで利用する場合 - 株式会社MIRAI

ここに書いてあります。つまり、除外設定から外して、コンパイルしてあげなきゃ駄目だよ、ってことだと思います。

公式サイトのAs an ES Module の欄にも書いてあります。

webpack.config.jsに、

exclude: /node_modules\/(?!(dom7|ssr-window|swiper)\/).*/,

を書いてあげる必要があります。