青いやつの進捗日記。

べんきょうのしんちょくをかいていきます。プログラミング初心者。

先日のエラーはXcodeのバージョンが問題でした。Unity ARKitプラグインのサンプルビルド出来ない人はバージョン確認しよう!

tech.motoki-watanabe.net

こんな感じで悩んでたんですが、

とあるエンジニアが集うSlackチームで聞いてみたところ

「いや、普通にできたよ」

と言われ…

とりあえずその人に環境に近づけるしかないと思い、

Xcodeを最新にしました。(9.4.1です)

ちなみにもともとは9.2でした。

そしたらですね、普通にエラー起きませんでした…

いやあ聞くべきは、ちゃんと聞ける相手ですね…

バージョンむやみに上げたら解決するわけでもにないかなって思ってビビってたのですがこういうこともあるのですね…

なにがともあれビルド出来たのでARKit関連もっといじっていきたい所存…!